Support » Asennus » Kysymyksiä

  • Hei
    Minulla on ongelmia wp:n asentamisessa. Etenin ohjeen mukaan päivittäen tietokantatiedot.
    Asennusohjeissa sanotaan kohdassa 4:
    ”Siirrä kaikki tiedostot palvelimelle.”
    1. Kysymys kuuluu mihin? public_html kansion alle? onko tämä oikea paikka? siirsin kokeeksi sinne.

    2. Kohdassa 5 ”Avaa /wp-admin/install.php selaimessa.” Tässä kohtaa selaimessa oli teksti, että wordpress olisi jo asennettu. Tämä ei ole mahdollista.

    3. Kohdassa 6. ”Muista ohjelman antama salasana.”. minulle ei tällaista tullut missään vaiheessa.

    Kiitos avusta

    Chiana

Esillä 3 vastausta, 1 - 3 (kaikkiaan 3)
  • Voit valita vapaasti, mihin WordPressin asennat – joko suoraan public_html-kansioon tai johonkin alihakemistoon.

    Salasanaa et saanut, koska asennus pysähtyi olemassaolevan asennuksen tuottamaan virheeseen.

    Se taas voi johtua esimerkiksi siitä, että tietokannassa on WordPressin taulut jo olemassa. Onko samalla palvelimella aikaisempia WordPress- tai bbPress-asennuksia?

    Thread Starter Chiana

    (@chiana)

    Hei

    Kiitos vastauksestasi. Ostin juuri palvelintilaa yleisestä palvelusta. Myöskään tietokantaani ei ole tullut yhtään taulua tämän asian tiimoilta. Tässä herjaava koodin pätkä. Koitin asentaa uudelleen, mutta sittekään en onnistunut ja tosiaan tietokantaani ei ole tullut yhtään mitään.
    Kiitos jälleen avusta.
    Chiana

    ”>
    WordPress

    ERROR: %s’), $error); ?>

    />

    ’.__(’Already Installed’).’

    ’.__(’You appear to have already installed WordPress. To reinstall please clear your old database tables first.’).’
    ’);} $php_version = phpversion(); $mysql_version = $wpdb->db_version(); $php_compat = version_compare( $php_version, $required_php_version, ’>=’ ); $mysql_compat = version_compare( $mysql_version, $required_mysql_version, ’>=’ ) || file_exists( WP_CONTENT_DIR . ’/db.php’ ); if ( !$mysql_compat && !$php_compat ) $compat = sprintf( __(’You cannot install because WordPress %1$s requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.’), $wp_version, $required_php_version, $required_mysql_version, $php_version, $mysql_version ); elseif ( !$php_compat ) $compat = sprintf( __(’You cannot install because WordPress %1$s requires PHP version %2$s or higher. You are running version %3$s.’), $wp_version, $required_php_version, $php_version ); elseif ( !$mysql_compat ) $compat = sprintf( __(’You cannot install because WordPress %1$s requires MySQL version %2$s or higher. You are running version %3$s.’), $wp_version, $required_mysql_version, $mysql_version ); if ( !$mysql_compat || !$php_compat ) { display_header(); die(’
    ’ . __(’Insufficient Requirements’) . ’

    ’ . $compat . ’
    ’); } switch($step) { case 0: case 1: // in case people are directly linking to this display_header(); ?>

    ReadMe documentation at your leisure. Otherwise, just fill in the information below and you’ll be on your way to using the most extendable and powerful personal publishing platform in the world.’), ’../readme.html’); ?>

    error) ) wp_die($wpdb->error->get_error_message()); display_header(); // Fill in the data we gathered $weblog_title = isset($_POST[’weblog_title’]) ? stripslashes($_POST[’weblog_title’]) : ”; $admin_email = isset($_POST[’admin_email’]) ? stripslashes($_POST[’admin_email’]) : ”; $public = isset($_POST[’blog_public’]) ? (int) $_POST[’blog_public’] : 0; // check e-mail address $error = false; if (empty($admin_email)) { // TODO: poka-yoke display_setup_form( __(’you must provide an e-mail address.’) ); $error = true; } else if (!is_email($admin_email)) { // TODO: poka-yoke display_setup_form( __(’that isn’t a valid e-mail address. E-mail addresses look like: username@example.com’) ); $error = true; } if ( $error === false ) { $wpdb->show_errors(); $result = wp_install($weblog_title, ’admin’, $admin_email, $public); extract($result, EXTR_SKIP); ?>

    admin
    ’. $password .’
    ’; } echo ’

    ’. $password_message .’
    ’; ?>”

    Jos asennus jostain syystä kuitenkin luulee, että tietokannassa on WordPressin tauluja, tarkistaisin tietokanta-asetukset.

    Tuliko tuo copy-pasteamasi pätkä näkyviin selaimessa, vai mistä sen kaivoit? Tuon ei missään nimessä pitäisi näkyä selaimessa, koska se on PHP-koodia, joka palvelimen pitäisi suorittaa. Jos tämä näkyi selaimessa, varmistaisin, että palvelimella on PHP-tuki varmasti käytössä ja kunnossa.

Esillä 3 vastausta, 1 - 3 (kaikkiaan 3)
  • The topic ‘Kysymyksiä’ is closed to new replies.