Support » Kokeneille käyttäjille » Ongelma Media-kansion kanssa

  • Nyt tarvittaisiin pikaista apua. Poistin wp-contents/uploads kansiosta kaiken sisällön, koska WPML-media translation -lisäosaa testattuani totesin että ihan turhaan tekee mediafileistä omat versiot joka kielelle (tuli kolminkertainen määrä tavaraa). BackUpista palautin sinne vanhan sisällön. Ok, kuvat sivuilla ovat ok ja viittaavat juuri oikeaan kansioon.

    Kun menen admintilassa Media-kansioon, se näyttää tyhjää. Kokeilin ladata jotain sinne, kaikki sujuu hyvin, mutta kun yritän sivupäivityksen kautta sieltä jotain liittää, ei siellä ole mitään. Olen kokeillut myös poistaa ja ruksata takaisin valinnaN ”Järjestä siirtämäni tiedostot kuukauden ja vuoden mukaan nimettyihin kansioihin”. Ei vaikutusta.

    Eli Admin paneelin kautta oleva Media-kansio on nyt ihan eri kuin aiempi wp-contents/uploads alla oleva media – sitä ei kuitenkaan fyysisesti mistään löydy. Miten tämän nyt saisi ratkaistua?

    Lisään vielä, että WP Super Cache oli käytössä, mutta senkin poistin käytöstä, arvellen että voisi vaikuttaa asiaan. Ei tulosta.

Esillä 5 vastausta, 1 - 5 (kaikkiaan 5)
  • Jaahas, sen verran tässä selvisikin, että uudet ladatut mediatiedostot ilmestyvät kyllä oikeaan kansioon, eli wp-contents/uploads, mutta edelleenkin jos yritän jollekin sivulle liittää jotain mediakansiosta, on se tyhjää täynnä ja toteamus ”Kohteita ei löytynyt. Pudota tiedostot tähän…” jne. killittää keskellä ikkunaa.

    Tämä virhetilanne WPML:n kanssa on tullut eteen. Eli Mediakirjasto tyhjenee.

    …/uploads kansioon Media/Lisää uusi kautta tai ftp:llä sinne siirretyt tiedostot eivät katoa minnekään. Fyysisesti ne eivät katoa ja sivusto toimii oikein – sivut hakevat kuvatiedostot oikein ko. hakemistosta. Ainoa mikä on rikki on se että Mediakirjasto tyhjä.

    Näin voi menetellä: jos haluat liittää kuvan jollekin sivulle, lataa se uudelleen Mediakirjastoon. Se menee sinne (ja fyysisesti …/uploads kansioon), ja saa siellä hiukan eri nimen. Sivusto toimii. Tee näin kuville joita sivustollasi jo on sekä uusille kuville.

    Eli ehdotan: Jos se toimii julkisella puolella, älä korjaa sitä.

    En ole löytänyt keinoa, jolla …/uploads kansion sisältö palautetaan Mediakirjastoon. Ehkä sellaisen lisäosan on joku tehnyt. Tai joku tietää jonkun keinon.

    Tämähän on aika paha bugi wpml:n taholta. Tosiaankin, vaikka palautin tilanteen mielestäni tilanteeseen ennen tuon WPML Media plugin aktivointia ja käyttöä (sekä sitten heivasin koko plugin hiiteen), on tilanne se että jokaisesta mediakansiossa olevasta dokumentista on yhtä monta versiota kuin on kieliversioita olemassa (siis näkyvissä Media-valikon kautta Admin paneelissa).

    Jos niistä yhdenkin poistaa, ei kyseinen kuva enää toimi missään kohtaa sivulla. Uusien kuvien lataus tosiaan sivupäivityksen yhteydessä toimii (eivätkä monistu enää), mutta niihin ei pääse sivupäivityksen ”lisää media” kautta käsiksi ollenkaan.

    Paha, paha juttu, kun asiakkaalle täytyisi ehjä systeemi tässä lähiaikoina esittää.

    Eli kyseinen virhetilanne on pysyvä, siihen ei enää korjausta ole, kun kerran on mennyt sen mokan tekemään, että käyttää WPML Media -plugia!(?)

    Olen saanut omalta osaltani ratkaistua tämän ongelman, eli nyt media-kansio ja sen sisältö toimii kuten pitääkin. Olen poistanut kaiken vanhan ja lisännyt median uudelleen. Tilanne ei korjaantunut vielä sillä.

    Sen jälkeen tarkastelin vähän wpml:n omaa foorumia ja sieltä näillä ohjeilla sain tilanteen siihen jamaan kuten sen pitää ollakin:

    1. Go to your Media Library and locate an image file. Click on ”Edit” to go to the ”Edit Media” screen of this file.

    2. Scroll all the way to the bottom of the page and look for the ”Make ’Media’ translatable” checkbox.

    3. It should be disabled. If it is already disabled, enable it first the save. Next disable it and save again. This will cause WPML to re-save its settings.

    4. Visit the ”WPML settings” (”WPML -> Support -> Troubleshooting”) again and search for [custom_posts_sync_option] you’ll see that [attachment] is on 0 as it should be*.

    * It should be either on 0 or not there at all!

    Kaikki media siis piti läpikäydä, onneksi tässä tapauksessa sitä ei ollut hirveän paljon.

    Mutta bugi siis on edelleen olemassa ja kannattaa harkita kahdesti, ennenkuin ryhtyy käyttämään WPML Media -modulia!

    Kiitos paljon – että sait ohjeen selville! 🙂

Esillä 5 vastausta, 1 - 5 (kaikkiaan 5)
  • The topic ‘Ongelma Media-kansion kanssa’ is closed to new replies.