Support » Ohjeet ja vianmääritys » Väliaikainen kansio puuttuu

  • Resolved Eravaeltaja

    (@eravaeltaja)


    Asensin uusimman WordPressin Louhen Basic webhotelliin.
    Kaikki muu näyttäisi toimivan, mutta mediakirjastoon ei saa ladatuksi mitään otsikon virheilmoituksen vuoksi.
    Olen perustanut public_html-hakemistoon /tmp/-hakemiston ja varmistanut, että upload_tmp_dir viittaa siihen.
    PHP.ini-tiedostoon en päässyt käsiksi, joten perustin tuon määrittelytiedoston päähakemistoon ja kirjoitin siihen:
    upload_max_filesize = 2M
    upload_tmp_dir = on
    upload_tmp_dir = /home/userxxx/public_html/tmp/
    Näillä tempuilla ongelma ei ratkennut. Mikä neuvoksi?
    Voisiko syynä olla tmp-hakemiston suojaus, jota en pääse c-Panelista muuttamaan?

Esillä 15 vastausta, 1 - 15 (kaikkiaan 19)
  • Moderator Mikko Saari

    (@msaari)

    Ei tuollaista omaa temppihakemistoa pitäisi tarvita perustaa, en minä ainakaan ikinä ole. Tästä kannattaa ottaa yhteyttä Louhen tukeen.

    Thread Starter Eravaeltaja

    (@eravaeltaja)

    Niin minäkin luulin. Kun kysyin Louhen tuelta WordPressin asennusohjetta, sain vastaukseksi: ”WordPress on mahdollista asentaa webhotelli Basic pakettiin manuaallisesti.”
    Onneksi WordPressillä oli paremmat asennusohjeet.
    Mutta tämä sama ongelma on maailmalla sangen hyvin tunnettu ja siitä on kirjoitettu paljon otsikolla: ”Missing a temporary folder” error with image upload.
    Neuvoja siihen löytyy monenlaisia ja sovelsin niitä kuvaamallani tavalla. Hakemiston suojauksestakaan asia ei ole kiinni.
    Voi ehkä olla, että systeemin php.ini-tiedosto ohittaa käyttäjän vastaavan. Käyttäjän kansioissa tuota tiedostoa ei ollut. Ei myöskään tmp-kansiota ennenkuin sen perustin.
    Tai sitten on kysymys ihan muusta virheestä hakemistopolun määrittelyssä tai ihan muualla sijaitsevan tmp-kansion käyttöoikeuksista.

    Moderator Mikko Saari

    (@msaari)

    Minulla on useampikin saitti ollut Louhella, eikä tuollaista ongelmaa ole vielä tullut vastaan, enkä ole koskaan perustanut temppihakemistoja käsin, missään.

    Kysypä Louhelta vielä tästä temppihakemistoasiasta, koska minusta tämä kuulostaa palvelinpään ongelmalta.

    Thread Starter Eravaeltaja

    (@eravaeltaja)

    Eipä vastannut Louhi perjantain kuluessa, joten pattitilanne jatkuu ties mihin saakka.

    Moderator Sami Keijonen

    (@samikeijonen)

    Oletko kokeillut asentaa WP:n uudelleen alusta ilman mitään temp-kansiosysteemiä? Kuten Mikko mainitsi, niin sellaiseen ei ole tarvetta.

    Thread Starter Eravaeltaja

    (@eravaeltaja)

    Enpä ole kokeillut paristakin syystä:
    1) Tein asennuksen aluksi ohjeiden mukaan koskematta mitenkään temp-hakemistoihin. Tein tmp-hakemistot vasta sitten, kun kuvien lataus ei pelittänyt.
    2) Olen ladannut jo kaikki vanhat sivut valmiiksi WordPressiin tosin ilman kuvia, kun niitä ei voi ladata. Pelkään, että uusi asennus tuhoaa tehdyn työn?

    Thread Starter Eravaeltaja

    (@eravaeltaja)

    Vaikeaksi menee. Louhen kommentti oli seuraava:
    ”Tämä virhe ei ole meille tuttu.”
    Konstit ovat aika vähissä.

    Moderator Sami Keijonen

    (@samikeijonen)

    Kokeile seuraavia konsteja.

    Ota kaikki lisäosat pois käytöstä ja vaihda oletusteemaan Twenty Fifteen. Kokeile vielä eri selaimellakin.

    Thread Starter Eravaeltaja

    (@eravaeltaja)

    Tein työtä käskettyä eli poistin kaikki lisäosat (2 kpl).
    Teema oli jo valmiiksi oletusteema.
    Käytin seuraavia selaimia:
    IE9
    Firefox
    Opera
    Chrome

    Virheilmoitus oli kaikilla selaimilla sama, kun yritin lisätä kuvan mediakirjastoon.
    Ei varmaankaan auta muu kuin yrittää uutta asennusta.
    Pitääkö nykyisestä WP:stä jotakin poistaa (miten) ennenkuin yrittää uutta asennusta? Nyt sivustolla on myös ftp:llä ladatut Front Pagella tehdyt aiemmat sivut, joita en haluaisi hävittää.

    Ja yksi lisäkysymys: Onko WordPressin käyttäjätunnus ja salasana riippumaton Louhen c-Paneelin hallintatunnuksista?

    Thread Starter Eravaeltaja

    (@eravaeltaja)

    Tämä vaikea keissi jatkuu, eikä mistään suunnalta ole ilmennyt pätevää neuvoa. Kansainvälisillä foorumeilla kirjoitetaan mm. seuraavasti:
    ————————————————————–
    Just a thought for everyone else who can’t access php.ini and doesn’t have shell access – maybe you can try and set the ini value upload_tmp_dir using the php command @ini_set(’upload_tmp_dir’,’/path/to/tmp’); using danoph’s suggestion to find your current working directory path. Instead of putting it in the file.php you can try to put it in the wp-settings.php file in the wordpress root. This may not work, however, if your host, like supanames, has no value set in the php.ini for upload_tmp_dir or doesn’t allow scripts to alter this value. Still, it maybe that there’s another way in the host’s control panel to set this value – for that you’d have to contact your own support I’d guess.

    finally, don’t forget you can check the current value of upload_tmp_dir in several ways but a simple php file containing the following script should tell you all you need to know:

    <?php
    var_dump(ini_get(’upload_tmp_dir’));
    ?>
    note: if it returns bool(false) it means upload_tmp_dir has no value.
    ————————————————————–
    En pääse käsiksi php.ini enkä file.php tiedostoihin.
    Tämänhetkinen käsitykseni on, että Louhen mahdollisesti hallinnoimassa serverin php.ini-tiedostossa on joko väärä määritys muuttujalle ’upload_tmp_dir’ ja/tai käyttäjä ei pääse sitä muuttamaan mitenkään.
    En tiedä, mihin hakemistoon tämä muuttuja lataustilanteessa osoittaa. Vaikutelmani on, että testauksessa muuttuja osoittaa käyttäjän päähakemistoon eikä sen /tmp-alihakemistoon. Ohjelmisto ehkä kieltäytyy päähakemistoon latauksesta?

    Mistä löytyisi seuraava viisastenkivi?
    Asennus kyllä vaatii käyttäjältä kohtuuttoman syvää WordPressin ymmärrystä tässä tapauksessa.

    Thread Starter Eravaeltaja

    (@eravaeltaja)

    Vihdoin löysin wp-koodista paikan, josta tämä virheilmoitus ilmeisesti tulee. Se sijaitsee tiedostossa:
    /wp-admin/includes/file.php
    Lainaus sieltä:
    ——————————————————————-
    if ( isset( $overrides[’upload_error_strings’] ) ) {
    $upload_error_strings = $overrides[’upload_error_strings’];
    } else {
    // Courtesy of php.net, the strings that describe the error indicated in $_FILES[{form field}][’error’].
    $upload_error_strings = array(
    false,
    __( ’The uploaded file exceeds the upload_max_filesize directive in php.ini.’ ),
    __( ’The uploaded file exceeds the MAX_FILE_SIZE directive that was specified in the HTML form.’ ),
    __( ’The uploaded file was only partially uploaded.’ ),
    __( ’No file was uploaded.’ ),
    ”,
    __( ’Missing a temporary folder.’ ),
    __( ’Failed to write file to disk.’ ),
    __( ’File upload stopped by extension.’ )
    );
    }
    ——————————————————————-
    Kukahan osaisi kertoa, mihin kohtaan tuossa tiedossa minun kannataisi sijoittaa käsky:
    var_dump(ini_get(’upload_tmp_dir’));
    saadakseni tietää, mihin tämä hakemistomuuttuja oikein osoittaa?
    Tämä tieto saattaisi olla ratkaisun avain.

    Tai sitten tieto siitä, missä php.ini tiedosto sijaitsee ja pääsekö käyttäjä siihen käsiksi millään keinoin. Louhen tuki vaikuttaa asiassa avuttomalta.

    Thread Starter Eravaeltaja

    (@eravaeltaja)

    Nyt taisi nytkähtää eteenpäin, mutta vielä ollaan kai Louhen armoilla.
    Sain listatuksi php-asetukset ja siellä sanotaan:
    upload_tmp_dir NO VALUE (Local) NO VALUE (Master)

    Mitähän nämä asetukset mahtavat olla toimivissa WP-asennuksissa?

    Miten loppukäyttäjä pääsisi asiaan vaikuttamaan?

    Thread Starter Eravaeltaja

    (@eravaeltaja)

    Varmuuden vuoksi asensin WordPressin uudestaan ja tulos oli yhtä masentava: ”Väliaikainen kansio puuttuu”.

    Kohta tarvitaan avuksi korkeampia voimia.

    Thread Starter Eravaeltaja

    (@eravaeltaja)

    Eipä sittenkään nytkähtänyt.
    Tässä tekstissä saattaa olla johtolanka:
    ——————————————————————–
    upload_tmp_dir is an optional setting in php.ini. Php will attempt to use the system default temp directory. So it should just work.

    If something happens to the permissions on your temp directory, regardless of wether you set it in php.ini or use the system default (usually /tmp on unix like systems), then media uploads will fail. You will see the same error ”Missing a temporary folder” if folder doesn’t exist, but also if you don’t have proper permissions on the temporary directory.

    Your web server, Apache or whatever, is probably running as nobody, or some other account with basically no rights to anything. So the first thing to check is that /tmp is globally writable.
    ——————————————————————-
    Sain nimittäin toisesta webbihotellistani varmistetuksi, ettei sielläkään php.ini -tiedosto sisällä upload_tmp_dir -muuttujan määrittelyä ja lataus siellä toimii.
    Vaikuttaa vahvasti siltä, että Louhi on estänyt latausta käyttämästä palvelimen tmp-kansiota. Jos Louhen ainoa viisaus on tässä: ”Tämä virhe ei ole meille tuttu.”, kilpistyy tämän webbihotellin käyttö tähän. Viulut on maksettu, mutta toimivaa sivua ei saada aikaan kuin mahdollisesti suurella lisärahalla.

    Thread Starter Eravaeltaja

    (@eravaeltaja)

    OMA APU PARAS APU – EIPÄ LÖYTYNYT TÄSTÄ MAASTA VIERASTA APUA!

    Sitkeä kokeilu tuotti tulosta, mutta 2 viikkoa siihen meni.

    Nyt voin antaa muillekin saman ongelman kimpussa askaroiville seuraavan kullanarvoisen neuvon:
    1) Jos päähakemistossasi (public_html) ei ole tiedostoa php.ini, luo se ja editoi sisällöksi
    upload_tmp_dir = ”/home/userxxx/public_html/tmp”
    2) Jos tuota tmp-hakemistoa ei ole olemassa, perusta se riittävin käyttöoikeuksin (0755).
    3) Kopioi kohdassa 1 mainittu php.ini -tiedosto myös alihakemistoon wp-admin.

    Tuo kohta 3 oli ratkaiseva. Sitä ei ollut neuvottu oikein missään.

    Aamen!

Esillä 15 vastausta, 1 - 15 (kaikkiaan 19)
  • The topic ‘Väliaikainen kansio puuttuu’ is closed to new replies.