Support » Lisäosat ja muokkaukset » WPML aktivointi, suomi muuttui englanniksi

  • Resolved Eemeli

    (@eemeli)


    Hei,

    mitähän tein väärin, kun suomenkielinen WP asennus muuttui englanninkieliseksi WPML:n aktivoimisen seurauksena. Ei auta, vaikka vaihdan Admin languagen suomeksi (joka siinä kylläkin jo on valittuna). Default language on myös suomi, mutta englanniksi vaan nyt kaikki hallintapuolella kuitenkin on. WPML bugi?

Esillä 9 vastausta, 1 - 9 (kaikkiaan 9)
  • Moderator Sami Keijonen

    (@samikeijonen)

    Mene kohtaan Users >> Your Profile. Siellä alhaalla on kohta WPML language settings, josta voit vaihtaa kielen.

    Sielläkin oli jo valmiina Current default language suomi. Kokeilin vaihtaa englanniksi ja takas suomeksi, mutta ei vaikutusta.

    Moderator Sami Keijonen

    (@samikeijonen)

    Laita viestiä WPML:ään mikä voisi mättää. Itselläni toimii kylläkin.

    mulla oli tää sama ongelma ja johtui ainoastaan siitä, että lisäosa etsi fi_FI.mo -tiedostoa, eikä tunnistanut fi.mo. Korjaantuu kun poistat ton ”_FI” käytettävästä tiedostonimestä.

    Mulla on valmiiksi fi.mo -niminen tiedosto… mutta missähän noista eri languages-kansioista tuon tiedoston muuten pitäisi sijaita? Tämä sijaitsee wp-content/languages.

    Tämä asia jäi osaltani roikkumaan, kun ei ollut pakottavaa tarvetta palata suomenkieliseen admin-hallintaan. Tässä jonkun päivityksen jälkeen muuttui osa suomenkieliseksi ja osa jäi enkuksi. Esim. vasemmasta yläreunasta alaspäin tultaessa: ”Ohjausnäkymä”, ”Etusivu”, ”Updates” jne englanniksi ”Mediaan” asti. Sitten taas ”Sivut”, jonka alla ”Comments” jne. Eli sattumanvaraisesti joko suomeksi tai englanniksi.

    Pääasia että kaikki toimii itse sivustossa ok.

    ei sun tarvi muuttaa mitään muuta kuin
    1) admin tunnareilla sisään wordpressiin
    2) klikkaa WPML -valikosta ”Theme and plugins localization”
    ja siellä kohta ”Language locale settings”

    Onko sulla alunperin suomenkielinen wp-asennus? (mulla oli)
    kannattaa myös asentaa WPML -päivitykset

    No niin. Kiitos! Nyt on ohjausnäkymä suomeksi, kuten pitikin alunperinkin!

    Siis ratkaistu.

    liian yksinkertainen ratkaisu 😉

Esillä 9 vastausta, 1 - 9 (kaikkiaan 9)
  • The topic ‘WPML aktivointi, suomi muuttui englanniksi’ is closed to new replies.